Firefox Browser Compatibility Issue

As of March 7, 2017, updated Firefox browsers may not work with the BAP CM/ECF site. Please use Internet Explorer or install the Firefox ESR 32-bit version. Instructions for installing the ESR 32-bit version (and the link to it) are in the document attached below.

Display On Pages: 
E-Filing (CM/ECF)
Court Docket (PACER)